[Logo] LDAPSoft LDAP And Active Directory Tools Community Forums
  [Search] Search   [Register] Register /  [Login] Login 
Messages posted by: Cheng
Forum Index » Profile for Cheng » Messages posted by Cheng
Author Message
Worked flawlessly. I did read all the online documentation, and never saw this.

Thanks for the help.
I have the latest Mac version, and verified it was up to date.

I have tried saving the file with all three variants of line endings: Mac, Unix and Windows ( CR, LF, CRLF) and it makes no difference. When I click the “Run SQL” button – it highlights all the lines, but the Confirmation Block comes back and only shows the First line and then if I hit OK I get an error. If I then highlight only one line and then accept the confirmation it works.

I need the ability to run several hundred lines of LDAP updates, and it isn’t working for me.
Here is an example of what I want to do:
Add an entry, modify an entry

## LDIF generated
#version: 1

#LDIF entry No : Add : 0
dn: Example=testAdd3,Example1=0,Example2=0,applicationName=appName, nodeName=node888
objectClass: Example
objectClass: MyObjectClass
groupId: 0
ownerId: 0
permissions: 9
shareTree: nodeName=node888
Example: testAdd3
MyAttribute: cc
MyAttribute: vv
MyAttribute: bb
MyAttribute: nn

#LDIF entry No : Modify 1
dn: Example=c,Example1=0,Example2=0,applicationName=appName, nodeName=node888
changetype: modify
delete: MyAttribute
MyAttribute: qq
add: MyAttribute
MyAttribute: aa

I will get the following error


: LDAPException: No Such Attribute (16) No Such Attribute
LDAPException: Server Message: NO_SUCH_ATTRIBUTE: failed for MessageType : ADD_REQUEST

Message ID : 13

Add Request :

: ERR_04269 ATTRIBUTE_TYPE for OID delete does not exist!

Note that it thinks both are add entries(see attached)

Am I doing something wrong?
I have an ldif file that i want to import. it has add entries and entries with changetype: modify. the import fails because the tool assumes all the entries are add. is this a known bug?
I can see it now. I tried different DCs before but didn’t display at that time. Another issue I think was that the attributes doesn’t sort alphabetically by default. Or it seemed anyway.

Thanks again.
I updated thumbnailPhoto attributes for a few users but I do not see this attibute in LDAP Admin tool pro. All I see i thumbnailLogo. I can see the attribute and that it has value in ADSIEdit.
I am running v 6.2
while I was trying to install the ldap soft a dialog box of notepad appears before i can continue the installation, what should I do next?
I exported all users with password to excel, but when I looked at the file it says {Binary Data} in the userPassword field.
How can I export the real values?
I have installed a Linux version of ldap admin tool 3 and am evaluating it. The browser functions are good and easy to understand.

My main questions is how to modify an existing group, such as add new members to and remove exiting members from a group – doing these in your GUI admin tools.

Does the trial version has all the functions enabled?
Forum Index » Profile for Cheng » Messages posted by Cheng
Go to:   
[Recent Topics] Recent Topics   [Hottest Topics] Hottest Topics   [Members]  Member Listing  
Powered by JForum 2.1.9 © JForum Team