[Logo] LDAPSoft LDAP And Active Directory Tools Community Forums
  [Search] Search   [Register] Register /  [Login] Login 
Messages posted by: Matthew
Forum Index » Profile for Matthew » Messages posted by Matthew
Author Message
That worked. Thank you very much!

And I also see that you need a - in between each enty and a blank line before each dn: entry when you want to update multiple entries.
I found the problem. I had to get the syntax EXACTLY right with regard to spaces:
1. Only 1 space after UPDATE/SET.
2. No space before or after =

I tweaked the query, ran it, and it did the update as expected.
I am trying to update the userPassword attribute for decendendant objects. I used the following sql:

UPDATE ou=People,o=jpmorgan.com SET userPassword = {SHA}yfmXWU8UG+QskqZgFjRr1BJiuTE= subtreescope

It did find all the entries, processed them, and said successfully updated. However, when I go back to verify the userPassword attribute, it is not the value that I set. I aslo know that it did update the value becuse the old value is not the same. So it has updated the value, but I don't know to what.

Also, when browsing the table view, I see that the value has been updated not to the exact value I specified, but rather to another value using SSHA.

I also tried the same update without specifying any encrytion as follows but I got the same results as above.

UPDATE ou=People,o=jpmorgan.com SET userPassword = testpw01 subtreescope
I am trying to change the userPassword attribute of a user. I tried putting one entry in an ldif file, listed below. When I import the file, I get: "Error: Unable to Read the fileC:\temp\LDAP\chpw.ldif"

The update does not take affect.

dn: uid=D102559,ou=People,o=jpmorgan.com
changetype: modify
replace: userPassword
userPassword: testpw01
Forum Index » Profile for Matthew » Messages posted by Matthew
Go to:   
[Recent Topics] Recent Topics   [Hottest Topics] Hottest Topics   [Members]  Member Listing  
Powered by JForum 2.1.9 © JForum Team